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1. Download Federal Electoral Districts and add to map document 
Federal Electoral Districts (FEDs) are the geographic areas for which one Member of Parliament is 

elected. It is downloaded as a shapefile which can then be viewed in ArcMap. 

1) In an internet browser, go to www.statcan.gc.ca  

2) After you’ve selected English, click Browse by key resource and select Maps and Geography 

3) Click on Geographic Products 

4) Click on Boundary Files 

5) Select 2011 as Census Year 

6) In the form, select English for Language, ArcGIS (.shp) as format, and Federal Electoral Districts 

(2003 Representation Order) – Cartographic Boundary File. 

 
7) Click Continue then select the link on the following page. It should look like this:  

 
8) Wait a moment for it to download. Spend that time trying to make sense of the gobbledygook 

name. Or not. We don’t care. 

9) Once it has downloaded, copy the ZIP folder into the project folder for today’s class. We suggest 

a hierarchy like this, but we’re particular about this stuff: 

http://www.statcan.gc.ca/
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10) Unzip the file. If you don’t, you’ll get an error when you try to import it into ArcMap. 

11) Your folder should now look something like this: 

 
This is as good a time as any to note that shapefiles look like multiple different files when you 

view them in Windows Explorer. If you ever copy and paste them somewhere, you need to have 

all the parts (e.g.: all the files that have the same name before the file extension – there may be 

up to 8 of them). 

12) You’re done the download! Yay! Give yourself a pat on the back! 

13) Now, open ArcMap by clicking on Start > Programs > ArcGIS > ArcMap. Once ArcMap opens, 

add the dataset by clicking on File > Add Data... Navigate to the project’s folder and find the 

shapefile. Click Ok to add the shapefile to ArcMap. 

 

14) In the Table of Contents, right click on Layers > Properties and select the Coordinate System 

tab. Scroll down and select the Layers folder. You’ll notice that the shapefile has a coordinate 

system of GCS_North_American_1983. This is important information for later on in the exercise. 

Click Ok to close the dialog box. 
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2. Add and Display Federal Contaminated Sites 
The Federal Contaminated Sites was downloaded as an Excel file. Included in the data of this Excel file 

are rows for latitude and longitude, which we’ll use to display in ArcMap. We’re in luck, because these 

latitude and longitude are in the same coordinate system as our Federal Electoral District boundaries. 

Yay! If you don’t have this file, go to http://madgic.library.carleton.ca/deposit/GIS/ and download it. 

1) In ArcMap, add the contaminatesSitesWorkbookforArcGIS.xlsx. Click on File > Add Data… 

1) ArcMap will then ask you which sheet you’d like to view. Select CleanXMLFile_2$

 
2) In the Table of Contents on the left, right click on CleanXMLFile_2$ and select Display XY Data... 

http://madgic.library.carleton.ca/deposit/GIS/
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3) In the following dialog, ensure that the X Field corresponds to Longitude and Y Field to Latitude. 

Notice here that we’ll be keeping the default coordinate system of the input coordinates to 

GCS_North_American_1983.  

 

4) Click Ok. This will display the longitude and latitude of each contaminated sites record for 

Canada in that particular coordinate system.  

5) In the Table of Contents, right click on CleanXMLFile_2$ Events > Data > Export Data…Save it 

your AmazingMap > Shapefile folder and name it contaminated_sites.shp. When prompted to 

add the file in ArcMap, agree. Now, we have a permanent point file of the locations of the 

contaminated sites. 
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6) You should now have 2 layers in ArcMap. In the Table of Contents, ensure that the 

contaminated_sites.shp is on top of the federal electoral district boundary.  

 

3. Querying and Extracting 
When confronted with a large dataset you may want to use the querying capabilities of ArcMap to 

extract one or more subsets. 

1) Right click on the contaminated_sites.shp in the table of contents, select Open Attribute Table. 

2) You will note that there are over 700 features in the dataset. In order to query the data, click on 

the Select By Attributes button  on the attribute table toolbar.  

3) The Select by Attributes dialog box will appear, which allows you to create a query statement 

that will select features that conform to the parameters you set. In this example, we will search 

for only high priority for Action sites. 
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a. Click the Verify button. You want to see this: 

 
b. If your expression was successfully verified, click Apply. You should notice at the bottom 

of the attribute table that it now says something like (648 out of 777 selected). Click the 

Show Selected Records button  in the attribute table to view only the selected 

features.  

c. Right click contaminated_sites.shp in the Table of Contents. 

d. Select Data > Export Data… 

e. In the Export Data dialog box, make sure Selected features is in the Export drop-down 

menu. 

f. Browse to where you would like to save your file. We recommend naming it something 

helpful, such as contaminated_priority.shp. Ensure that you Save as type Shapefile. 

Click Save. 

g. Click OK. 

h. Wait for the Export Progress box to complete.  

i. Click Yes to add exported data to map as a layer. 

j. Click on the checkbox beside contaminated_sites to turn it off and view only your new 

layer. 

 

Field names 

Query components 

Query statement 
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4. Calculate how many points are found in a polygon 
Sometimes it is helpful to know how many instances of something (like contaminated sites) occur within 

a particular area (like FEDs).  

1) Right click on the FED shapefile (gfed000b11a_e) and select Zoom To Layer to view it at its 

extents. It should look something like this with the contaminated_priority layer turned on as 

well. 

 
2) In order to find out how many high priority contaminated sites are in each FED, we will perform 

a spatial join. Right-click on gfed000b11a_e. Select Joins and Relates > Join… 

3) Fill out the Join Data dialog box as seen here: 

a. Join data from another layer based on spatial 

location (we want to find out which high 

priority points fall within the FED polygons) 

b. Choose the layer: contaminated_priority 

c. Summarize by Sum (this will provide a total 

number of contaminated sites within each 

electoral district) 

d. Browse to the location you wish to save your 

resulting shapefile, and name it something 

helpful like FED_PrioritySites. 

4) Click OK 

5) FED_PrioritySites will be added to your map. Right-

click and Open Attribute Table. 

6) Note the Count_ field. This gives a total of 

contaminated sites within each electoral district. 

7) Double-click on the Count_ field name to sort it 

numerically (ascending). Double-click it again to sort 

descending. 

8) To symbolize the FED_PrioritySites shapefile based on the Count_ field, close the table and in 

the table of contents right-click FED_PrioritySites and select Properties… 

9) Click the Symbology tab in the Layer Properties dialog box. 

10) Click Quantities > Graduated Colors. 
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11) Fill it in as seen below: 

 
a. Value field should be Count_ 

b. Pick your favourite colour ramp. As you are showing density, go with something that’s 

the same hue but with varying intensity. If you go with a many-coloured ramp your map 

becomes meaningless, like so: 
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12) Your on-screen map should now look something like this, with the darker hues showing us which 

FEDs have the most contaminated sites.

 

13) Let’s not spend too much time here as section 8 focuses on creating our map layout and making sure 

that our map looks just right! 

5. Extracting British Columbia FEDs  
Selecting features from a shapefile allows users to identify or more easily locate a subset of features on 

your map. You’ll most likely work with selected features when you are querying, exploring, analyzing, or 

editing data. Applying a selection is also a way of specifying the features for which you want to calculate 

statistics, view attributes, move, export as a new layer, and so on. 

1) Right-click on FED_PrioritySites and select Open 

Attribute Table 

2) Click the attribute table menu drop-down arrow and 

select Select by Attributes… or click the Select by 

Attributes button:  

3) Like with the querying we did earlier, we will construct 

an expression to select only FEDs in British Columbia. 

In this case, the expression is "PRNAME" LIKE 'British 

Columbia / Colombie-Britannique' 

4) Click the Verify button to confirm that the expression 

is valid. 

5) Click Apply. You should now have 36 of 308 selected 

in the attribute table. 

6) Close the Select by Attributes window. 

7) We’re now going to export ONLY the selected British 

Columbia FEDs. To do this, right click 

FED_PrioritySites. 
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8) In the menu, select Data… > Export Data… 

9) In the dialog box, make sure that it says Export: Selected Features (as shown below) 

 
10) Browse to your project folder and save the file. We saved it as FED_PrioritySites_BC.shp. 

11) Add it to your map when prompted. 

6. Downloading and Joining Census Data 
We now want to look at the census data for the FEDs in British Columbia to perhaps find a pattern. The 

Census includes information about population & language while the National Household Survey (NHS) 

includes data about income, immigration, workplace, and more.   

1) We’re going to use the Canadian Census Analyzer from the University of Toronto. The URL is 

http://dc1.chass.utoronto.ca.proxy.library.carleton.ca/census/. You will need to be on Carleton 

campus or sign in with your Carleton ID from elsewhere. 

2) On the resulting page, click Federal Electoral District from the list under Census Profile Tables. 

3) Then select 2011 (cumulative) FEDs 2003 Representation Order. The following page is where 

we’ll make our selections.  

4) UNCHECK the checkbox by the letter A in the by Name tab. 

5) Click the by Province tab and select British Columbia. In the resulting list below, click the check 

all link. 

 
6) Scroll down to Step 2: Specify NHS Profile Variables for Retrieval and click the Inc tab (far right) 

7) Check off Total income in 2010, Median income, and Average income 

http://dc1.chass.utoronto.ca.proxy.library.carleton.ca/census/
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8) Scroll down to Step 3: Specify the output details and submit query 

9) Include Province Code and FED Code in the result 

 
10) Because the data will be joined to a shapefile, select dBase (DBF) file as output format 

11) Click Submit Query then download both files (data and header) and save in project folder. Next, 

we’ll join the NHS data to the FED_PrioritySites_BC shapefile in ArcMap. 

12) In ArcMap, right click FED_PrioritySites_BC, the select Joins and Relates>Join….  

13) We will do a non-spatial join by joining attributes from a table, so select Join attributes from a 

table in the drop-down menu. 

14) In #2, browse to the NHS data file in DBF format that is in your project folder. 

15) Return to #1 and select FEDUID as the field to match. 
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16) In #3, select COL0 as the field in the table to base the join on. (You can figure out it’s COL0 by 

looking at the header file and noting that it’s the GEOUID.) 

17) Click OK. 

 

18) To make the join permanent, we have to export the data. But before doing so, let’s change the 

coordinate system of our map.  As we saw earlier, the current coordinate system of the map is 

GCS_North_American_1983. This coordinate system is not a proper coordinate system to use 

for this particular area as if doesn’t properly display our information cartographically. In 

addition, if we were ever to take any measurements, they would be somewhat meaningless as 

these would be done in degrees, seconds and minutes.  
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19) To change the coordinate system, in the table of contents, right click on Layers > Properties.  

Select the Coordinate System tab and in the search box, type in Canada Lambert Conformal 

Conic.  Select Canada Lambert Conformal Conic and click Ok. 

 

20) Now, let’s make that join permanent. In the table of contents, right click FED_PrioritySites_BC > 

Data > Export Data… Make sure you select the data frame coordinate system (which we setup 

in the previous step). Save the file as FED_PrioritySites_BC_IncomeLCC.shp 

 

21) When asked to add the layer to the map, say yes. 

22) Remove the FED_PrioritySites_BC from the table of contents. 
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7. Symbology and labels 
Let’s take a look at how we can use symbology and labels to provide us with layers of information from 

the same shapefile. 

1) Open the attribute table for FED_PrioritySites_BC_IncomeLCC to view the table with the NHS 

data joined to it. Note that the column names for the table are not helpfully named. We can 

change that! 

2) Right click on FED_PrioritySites_BC_IncomeLCC and select Properties…. 

3) Click on the Fields tab 

4) On the left you will see a list of all the fields. Scroll to the bottom to see COL0, COL1, etc. COL3, 

COL4 and COL5 are the ones we are interested in as they have the income data as noted in the 

header file. On the right of the window, change the Alias to something helpful for each field. 

Use the header file that was downloaded from the census analyzer if you forget what COL3, 

COL4 and COL5 mean. This is what will be displayed in the attribute table. Click Apply when 

done. 

 

 
5) Change the symbology of FED_PrioritySites_BC_IncomeLCC to a colour ramp based on Average 

Income. (Refer back to page 6 if you need a quick reminder on how to do that.) Click Apply. 

6) Now let’s label each FED with the number of high priority contaminated sites! Whee! 

7) In Properties, select the Labels tab. 

8) Check the Label features in this layer box, with method Label all features the same way. 

9) Set the label field to Count_. 

10) Choose your label font. In the example it’s Arial, size 12, bold, white. 
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11) Click OK. 

 
12) Your map should now look something like this: 
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8. Creating a Map Layout 
To create a map layout, you'll want to work with it in layout view.  In layout view, you will be able to 

place and arrange map elements such scale bar, a legend and a map title.  

1) In the menu, select View > Layout View. This will open the Layout view with your current map. 

To return to the previous view, click on View > Data View. 

2) You’ll notice that the default layout view is in portrait mode. Since the shape of the city of 

Ottawa is better viewed in landscape, in the menu, click on File > Page and Print Setup. Change 

the orientation to Landscape. You may also want to change the units of measurement from 

centimeters to inches. Click Ok. 

 
 

3) Resize the grid around the map to match up with the dotted lines in the layout view. The dotted 

lines represent the margins of the layout. 

4) Using the zoom and pan tools from the Tools Toolbar, zoom into your area of the map. Please 

keep in mind that there are two types of zoom tools available as indicated below. 

 

5)   
6)  

12) For map layers to display with meaningful labels in your map layout, change the layer name in 

the Table of Contents. 

a. In the Table of Contents, double click on the name of the layer that you want to change. 

b. In the Properties Window click the General tab. 

c. Change the layer name to your desired name and click Close. 

13) Change the colours and symbols of the shapefiles 

a. In the Table of Contents, double click on the symbol and in the symbol selector window, 

select the desired colour, size and symbol. 

Tools Toolbar 

Layout View Toolbar 
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Adding Other Map Elements 

Adding a North Arrow 

1. In the menu, select Insert > North Arrow. 

2. Select a north arrow and click OK. The north arrow will be added to a random location on the 

map, usually somewhere in the centre. 

3. Click and drag the north arrow into place on your map. 

4. Resize the north arrow by clicking and dragging a selection handle. 

Adding a Scale Bar 

1. In the menu, select Insert > Scale Bar. 

2. Select a scale bar and click Ok. 

Optional: If you’d like to edit in more detail the scale bar, follow these instructions. 

3. Click Properties to modify the scale bar’s properties. 

4. Click the Scale and Units tab. 

5. Click the arrow buttons to set the number of divisions. 

6. Click the arrow buttons to set the number of subdivisions. 

7. Click the When resizing drop-down arrow and click how you want the scale bar to respond when 

the map scale changes: 

a. Adjust width – the width of the scale bar will vary with the map scale. The division value 

and number of divisions remain constant. 

b. Adjust division value – the division value will vary with the map scale. The number of 

divisions and the width of the scale bar remain constant. 

c. Adjust number of divisions – the number of divisions will vary with the map scale. 

8. Choose the units for the scale bar. 

9. Click Symbol and choose a test style for the scale bar labels. 

10. Click OK and OK again to close the dialog box. 

11. Click and drag the scale bar into place on your map. 

Adding a Legend 

1. In the menu, select Insert > Legend. The Legend wizard appears. 

2. By default, all the layers on the map will appear as legend items in the legend. To remove a 

legend item, select it, and click the left arrow button. 

3. Use the Up and Down arrow buttons to order the legend items. 

4. Click Next. 

5. Type a title for the legend. 

6. Set the text color, font, and size as desired, and click Next. 

7. Select a border, background and/or drop shadow as desired by clicking their respective drop-

down boxes. Click Next. 
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8. Select a legend item in the list to modify the symbol patch. 

9. Set the patch properties as desired and click Next. 

10. Set the spacing between legend elements by typing a value in the appropriate box. 

11. Click Finish. 

12. Click and drag the legend into place on your map. 

Adding a Title to a Map 

1. In the menu, select Insert > Title. 

2. Type in the title in the box. Click OK. 

3. Click and drag the title into place on your map. 

4. The title can also be formatted using the Draw toolbar. 

 

 


